Erst vor zwei Tagen, am 25. Mai, ist Version 3.1.3 der Blog-Software WordPress (wordpress.org) erschienen. Und schon macht ein enthaltener Bug die Runde.

Warning: in_array() expects parameter 2 to be array, null given in .../wp-includes/query.php on line 2399

Dieser Fehler erscheint beim Aufruf der Mediathek. WordPress gab bekannt, dass (erst) in Version 3.1.4 dieser Fehler behoben sei - er sei ungefährlich. 😉

Quellen: wordpress.org und core.trac.wordpress.org

Deine Meinung zu diesem Artikel?


4 Kommentare zu "WordPress: 3.1.3: "Warning: in_array() expects parameter 2 to be array, null given in .../wp-includes/query.php on line"" (RSS)

Matthias
Vielen Dank für den Beitrag! Ich dachte schon, ich hätte was falsch gemacht, weil es nicht bei allen meiner Blogs auftaucht und ja irgendwie schon komisch aussieht...
Chris
Gerne - ging mir ähnlich 😉
Jochen
Weisst du zufällig auch, wodurch dieser Fehler auftritt?

MFG
Chris
Die genauen Gründe samt Quellcodeauszug (Vergleich 3.1.2, 3.1.3 und 3.1.4) findest du unter http://core.trac.wordpress.org/ticket/17556. 🙂

Ein Trackback oder Pingback zu "WordPress: 3.1.3: "Warning: in_array() expects parameter 2 to be array, null given in .../wp-includes/query.php on line""

Wordpress 3-1-1 Medienupload-Problem | Infopool für Webmaster und Blogger
[...] Servaholics.de geht es um denselben Query.php-Fehler, also ist es ein Fehler bei jeder 3.1.3-WP-Installation. Na [...]